
Talking PIM

Talking PIM provides an easy-to-use way of managing your schedule (such as business appointments, 
lunches, birthdays, phone calls, and so forth) and your business contacts. Talking Clock (rather than 
Talking PIM) can then be used to alert you when its time for an appointment.

Note: If you save changes to your Schedule Book in Talking PIM while Talking Clock is running, exit and 
restart Talking Clock so it can pick up the changes.
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Creating New Appointments

To add an appointment:

1. Open the Appointment dialog:

* Double click a time slot in Day view or

* Select a contact name, then drag-and-drop it onto a time slot 
in Day view or

* Choose New appointmentÖ from the Edit menu in any view or

* Press CTRL+A in any view

The Appointment dialog appears.

2. Specify all options that apply to your appointment (such as message,
duration, type, time, media element (by way of the Sight/SoundÖ button), 
and so forth).

3. After you finish specifying the options, choose OK to create the 
appointment or Cancel to abandon it.

See also Viewing Appointments, Editing Appointments, Deleting Appointments, and Saving Schedule 
Books.



Appointment Dialog

You can specify the following options when you create or edit an appointment:

Option Function
Message The message that appears for the appointment in Day, Week, or Month View and

in Talking Clocks alarm dialog. If you have the speech synthesis module installed,
Talking Clock also reads the message when it announces the appointment. The 
message can be anything you want that describes the appointment (such as 
"Meet with Joe").

Note: If you dragged a contact name onto a time slot in Day view 
to create the appointment, the message lists the contacts name.

Frequency Determines how often to announce the alarm. You can choose from
daily, every other week, monthly by date or by weekday, once only, weekdays, 
weekends, weekly, and yearly by date or by weekday.

Type Determines the appointment type, which determines how to announce the 
appointment and which icon represents it in Talking Clocks alarm dialog.

Date Determines the appointment day(s). Depending on the frequency, not all day 
options are selectable (for example, only the day of the month can 
be selected for monthly appointmentsthe other day options are ignored).

Time Determines appointment time. If the appointment doesn't have a specific time 
(such as a birthday or holiday), you may use any time. Adjust the time by clicking 
its scroll-box arrows or by dragging its scroll box.

Duration Determines an appointments duration. Adjust the duration by clicking
its scroll-box arrows or by dragging its scroll box. The display is in hours:minutes 
format. 

Display alarm dialog Determines whether Talking Clock displays its alarm dialog when it announces 
the appointment. By default, this dialog appears 10 minutes before your 
appointment and lets you put off the alarm for 10 minutes (a.k.a. the snooze 
option).

Announce appointment Determines whether Talking Clock announces the appointment's type and time.

None Disables the Play media element and Program run options.

Play media element Enables the Sight/SoundÖ button. If you choose the button, you may select a 
media element to play at the appointment time. See Adding/Editing Media 
Elements.

Run program Enables the ProgramÖ button. If you choose the button, you may specify a 
program to play at the appointment time. See Adding/Editing Program Runs.



Viewing Appointments

Talking PIM provides several different ways of viewing appointments:

* Day view, which shows all appointments for a given day

Access Day view by choosing the Day view button (D) button 
in the button bar or choose Day from the View menu

* Week view, which shows all appointments for a given week

Access Week view by choosing the Week view button (W) button 
in the button bar or choose Week from the View menu

* Month view, which shows all appointments for a given month

Access Month view by choosing the Month view button (M) button 
in the button bar or choose Month from the View menu

* Appointment dialog, which lets you view and change specific details 
about a single appointment, such as its duration, time, or frequency

Appointment dialogs are accessible in many different ways, depending
on whether youre adding or editing appointment information. Refer to
Creating New Appointments and Editing Appointments for more information.



Editing Appointments

Talking PIM provides several ways to edit appointments:

General Appointment Editing
Editing Appointment Time Slots
Editing Appointment Durations
Adding/Editing Media Elements
Adding/Editing Program Runs



General Appointment Editing

To edit general appointment information:

1. Open the Appointment dialog

* Double click the appointment in Day view or

* Choose PropertiesÖ from the Edit menu in Day view

The Appointment dialog appears.

2. Edit any options that you want to change (such as message, 
duration, type, time, media element (by way of the Sight/SoundÖ 
button), and so forth).

3. Choose OK to save the changes to the appointment 
or choose Cancel to abandon them.

See also Viewing Appointments, Deleting Appointments, and Saving Schedule Books.



Editing Appointment Durations

To edit an appointments duration:

1. Move the cursor over the lower-edge of the selected appointment 
in Day view. 

The cursor changes to a resize cursor (double-edged arrow).

2. Press the PRIMARY MOUSE button and vertically drag 
the lower-edge of the appointment to the desired duration 
(for example, drag a 10:00 to 11:00 am meeting down to 
11:30 am).

Heres another way of editing an appointments duration:

1. Open the Appointment dialog

* Double click the appointment in Day view or

* Choose PropertiesÖ from the Edit menu in Day view

The Appointment dialog appears.

2. Click the Duration scroll-box arrows or drag the Duration scroll box 
to the desired time duration (such as 1:30 for 11/2 hours).

3. Choose OK to save the change to the appointment or 
choose Cancel to abandon it.

See also Viewing Appointments, Deleting Appointments, and Saving Schedule Books.



Editing Appointment Time Slots

To edit an appointments time slot:

1. Move the cursor over the appointment in any view. 

The cursor changes to a pointing hand.

2. Press the PRIMARY MOUSE button and drag-and-drop the 
appointment to or press CTRL+X and drop the appointment onto

* Day view: Another time slot (for example, move the 
10:00 am time slot to the 3:00 pm time slot).

* Week and Month views: Another day (for example, 
move the 10:00 am October 7 appointment to October 20 
(keeps the same time slot))

Heres another way of editing an appointments time slot:

1. Open the Appointment dialog

* Double click the appointment in Day view or

* Choose PropertiesÖ from the Edit menu in Day view

The Appointment dialog appears.

2. Click the Time scroll-box arrows or drag the Time scroll box 
to the desired time slot (such as 3:00p).

3. Choose OK to save the change to the appointment or 
choose Cancel to abandon it.

See also Viewing Appointments, Deleting Appointments, and Saving Schedule Books.



Adding/Editing Media Elements

To add or edit a media element you want to play at the appointment time:

1. Open the Appointment dialog

* Double click the appointment in Day view or

* Choose PropertiesÖ from the Edit menu in Day view

The Appointment dialog appears.

2. Choose Play media element.

3. Choose Sight/SoundÖ.

The Choose Media Element dialog box appears.

4. Select a media element from the Media element or File name list.
Change Directories and Drives as necessary.

Note: If you dont want to play a media element, select (none).

5. Choose OK.

6. Choose OK again to save the change to the appointment 
or choose Cancel to abandon it.

See also Viewing Appointments, Deleting Appointments, and Saving Schedule Books.



Adding/Editing Program Runs

To add or edit a program specification that you want to run at the appointment time:

1. Open the Appointment dialog

* Double click the appointment in Day view or

* Choose PropertiesÖ from the Edit menu in Day view

The Appointment dialog appears.

2. Choose Run program.

3. Choose ProgramÖ.

The Command Line dialog box appears.

4. Enter the path of a program you want to run in the 
Command line box (for example, D:\WINWORD\WINWORD.EXE).

Note: You may also specify a command-line argument 
with the program you want to run (for example, 
D:\WINWORD\WINWORD.EXE D:\DATA\PRIVAT.DOC).

You may also choose BrowseÖ to locate a program to run. 
When the Open dialog box appears, select a program to run, 
changing Directories and Drives as necessary, then choose OK.

If you dont want to run a program, leave this field blank.

5. Choose OK.

6. Choose OK again to save the change to the appointment 
or choose Cancel to abandon it.

See also Viewing Appointments, Deleting Appointments, and Saving Schedule Books.



Deleting Appointments

To delete an appointment:

1. Move the cursor over the appointment in any view. 

The cursor changes to a pointing hand.

2. Press the PRIMARY MOUSE button to select the appointment.

3. Press the DELETE key.

The appointment is deleted. 

If you really didnt want to delete the appointment and you want to restore it, immediately:

* Press CTRL+Z or

* Choose Undo from the Edit menu

See also Viewing Appointments and Saving Schedule Books.



Printing Appointments

To print your appointments for the current day, week, or month:

1. Choose the view (that is, Day, Week, or Month) that you want to print.

2. Access the Print dialog:

* Choose the Printer button in the button bar or

* Choose Print from the File menu or

* Press CTRL+P

The Print dialog box appears.

3. Select your print options (such as Print Range or Number of copies).

4. Choose OK to print the view.



Creating New Contacts

To create a new business contact:

1. Change to Day or Contacts view:

* Choose the Day or Contacts view button in the button bar or

* Choose Day or Contacts from the View menu

2. Choose New contactÖ from the Edit menu.

The Contact Information dialog box appears with blank fields (default).

3. Enter the information that you want to track (such as the contacts 
name, company, address, E-mail address, voice and fax numbers,
and notes).

4. Choose OK.

The contacts name and phone number now appear in the 
Contact area of the Day view.

See also Viewing Contact Information, Editing Contact Information, Deleting Contact Information, and 
Saving Schedule Books.



Viewing Contact Information

To view your business contact information:

* Choose the Contact button in the button bar or

* Choose Contact from the View menu



Editing Contact Information

To edit a business contact:

1. Change to Day or Contacts view:

* Choose the Day or Contacts view button in the button bar or

* Choose Day or Contacts from the View menu

2. Access the Contact Information dialog:

* Double click the contact information you want to edit

* Select the contact you want to edit, then choose PropertiesÖ 
from the Edit menu

The Contact Information dialog box appears.

3. Edit the information that you want to change (such as the contacts 
name, company, address, E-mail address, voice and fax numbers,
or notes).

4. Choose OK.

The contacts name and phone number reappear in the 
Contact area of the Day view.

See also Viewing Contact Information, Deleting Contact Information, and Saving Schedule Books.



Deleting Contact Entries

To delete a business contact:

1. Change to Day or Contacts view:

* Choose the Day or Contacts view button in the button bar or

* Choose Day or Contacts from the View menu

2. Select the contact you want delete.

3. Press the DELETE key.

The contacts name and phone number reappear in the 
Contact area of the Day view.

If you really didnt want to delete the contact and you want to restore it, immediately:

* Press CTRL+Z or

* Choose Undo from the Edit menu

See also Viewing Contact Information and Saving Schedule Books.



Printing Contact Lists

To print your contact list:

1. Choose Contacts View.

2. Access the Print dialog:

* Choose the Printer button in the button bar or

* Choose Print from the File menu or

* Press CTRL+P

The Print dialog box appears.

3. Select your print options (such as Print Range or Number of copies).

4. Choose OK to print the view.

See also Viewing Contact Information.



Using Schedule Books

A schedule book is a file (*.APP file) that contains your appointments and business contacts.
If different users use the same machine, they may each want a separate schedule book. With Talking 
PIM, you can maintain separate schedule books and copy appointments between them.

Creating New Schedule Books
Opening Schedule Books
Saving Schedule Books
Holidays



Creating New Schedule Books

You can create a new schedule book by choosing Blank Page button in the button bar or choose New 
from the File menu. If you've made changes to the currently loaded schedule book, you'll be prompted to 
save it first. A new schedule book does not have any appointments defined; however, it does contain 
default holiday information provided with Talking PIM.



Opening Schedule Books

To open an existing schedule book, choose the Open Folder button in the button bar or choose OpenÖ 
from the File menu. If you've made changes to the currently loaded schedule book, youll be asked to save
the changes first. The title of the Talking PIM window reflects the currently loaded schedule book.



Saving Schedule Books

To save the currently loaded schedule book, choose the Floppy button in the button bar or choose Save 
from the File menu. If you haven't given it a name yet, you'll be prompted to give it a name and to specify 
where to save it.

If you'd like to save a schedule book under a new name, choose Save AsÖ. You'll be prompted 
to supply a name and specify the directory in which to save the schedule book. If you choose the name of
an existing schedule book, Talking PIM will overwrite it with the schedule information you're saving. For 
this reason, you'll be asked for confirmation if you choose an existing name. This option will not remove or
alter the schedule book with the currently loaded schedule book's previous name.

Both the Save and Save AsÖ options let you save to the Appointment file (*.APP) format. The last *.APP 
file open becomes the default schedule book. The default schedule book automatically loads when 
Talking PIM and Talking Clock load.



Holidays

Talking PIM includes a standard set of holidays in its default schedule book. If you want to add additional 
holidays (standard or personal), follow the instructions in the Creating New Appointments section and 
select the appropriate holiday type from the Type drop-down list box.



Miscellaneous

Besides using the Cut, Copy, and Paste buttons in the button bar, you can do other things with Talking 
PIM:

Selecting an Alarm Voice
Selecting an Alarm Face
Changing the Background
Using the Calculator
Saying the Time
Saying the Date
Saying Your Schedule

Note: We dont explain how to cut, copy, and paste, as were assuming youve cut, copied, and pasted stuff 
before.



Selecting an Alarm Voice

You can select a voice for Talking Clock to use when it announces your appointments. To do this, choose 
the Lips button from the button bar or choose Voice Setup from the Edit menu. When the Voice dialog box
appears, select a voice, then choose OK.

Note: If you later specify a Voice Scape setting with the MediaScape Changer application (provided with 
Wired for Sound Pro/Wired for Sound Pro CD), the new scape setting overwrites the settings youve 
specified here. If you still want a different voice announcing your appointments, repeat the Voice Setup 
process from within Talking PIM.



Selecting an Alarm Face

You can select an animated face for Talking Clock to use when it announces your appointments. To do 
this, choose the Smiley Face button from the button bar or choose Face Setup from the Edit menu. When 
the Choose Face dialog box appears, select a face, then choose OK.

Note: If you later specify a Face Scape setting with the MediaScape Changer application (provided with 
Wired for Sound Pro/Wired for Sound Pro CD), the new scape setting overwrites the settings youve 
specified here. If you still want a different face announcing your appointments, repeat the Face Setup 
process from within Talking PIM.



Changing the Background

You can change the view background from the Windows default to one of the month or seasonal bitmaps 
provided with Talking PIM. To do this, choose BackgroundÖ from the Edit menu. When the Open dialog 
box appears, select a bitmap file, then choose OK. Choose BackgroundÖ again to return to the Windows 
default.



Using the Calculator

You can calculate numbers by choosing the Calculator button in the button bar (the button with 
1 2 3 across the top). This accesses Talking Calculator (provided with Wired for Sound Pro/Wired for 
Sound Pro CD), which works similar to the standard Windows calculator, except ours TALKS.



Saying the Time

You can announce the current time by choosing the Say Time button in the button bar (the balloon with 
the clock hands in it). You can also do this by pressing CTRL+T or by choosing Time from the Say menu.



Saying the Date

You can announce the current date by choosing the Say Date button in the button bar (the balloon with 
the 17 in it). You can also do this by choosing Date from the Say menu.



Saying Your Schedule

You can announce the selected dates (highlighted) schedule by choosing the Say Schedule button in the 
button bar (the balloon with the light bulb in it). You can also do this by pressing CTRL+H or by choosing 
Schedule from the Say menu.



Schedule Book

A file that contains appointments and business contacts. You can have multiple schedule books on one 
machinefor instance, one for each user, or one for different types of appointments or contacts.



Alarm Dialog

A dialog displayed by Talking Clock if youve selected the Display alarm dialog in Talking PIMs Alarm 
dialog. By default, this dialog appears 10 minutes before your appointment and lets you put off the alarm 
for 10 minutes (a.k.a. the snooze option).



Media Element

A media element is any multimedia file, such as a sound file (waveform or MIDI), a video clip (such as 
AVI), or a Windows bitmap. If you have the speech synthesis module, text files are also treated as media 
elements--they are read by the synthesis engine when played. Generally, Talking PIM lets you specify any
type of media element to play as appointment alarms.

Note: Talking Clock, rather than Talking PIM, plays the media element selected as an appointment alarm. 
To hear appointment alarms, you must be running Talking Clock.




